fix timestamp in Russian day change message
[quassel.git] / src / client / CMakeLists.txt
index e7e9e4d..b8b14e1 100644 (file)
@@ -1,10 +1,19 @@
 # Builds the client module
 
-# We still have some minor deps to QtUi: QItemSelectionModel
-# set(QT_DONT_USE_QTGUI 1)
-set(QT_USE_QTNETWORK 1)
-set(QT_USE_QTDBUS 1)
-include(${QT_USE_FILE})
+# In Qt4, we still have some minor deps to QtUi: QItemSelectionModel, QSortFilterProxyModel
+# Still in Qt5: QAbstractItemView in BufferModel
+
+set(_modules )
+
+if(WITH_QT5)
+  list(APPEND _modules Widgets)
+endif(WITH_QT5)
+
+if(HAVE_DBUS)
+  list(APPEND _modules DBus)
+endif(HAVE_DBUS)
+
+setup_qt_variables(Gui Network ${_modules})
 
 set(SOURCES
     abstractmessageprocessor.cpp
@@ -14,14 +23,20 @@ set(SOURCES
     buffersettings.cpp
     bufferviewoverlay.cpp
     client.cpp
+    clientaliasmanager.cpp
     clientbacklogmanager.cpp
     clientbufferviewconfig.cpp
     clientbufferviewmanager.cpp
+    clientcoreinfo.cpp
     clientidentity.cpp
+    clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
-    clientsyncer.cpp
     clientuserinputhandler.cpp
+    coreaccount.cpp
+    coreaccountmodel.cpp
+    coreconnection.cpp
+    execwrapper.cpp
     irclistmodel.cpp
     messagefilter.cpp
     messagemodel.cpp
@@ -35,14 +50,18 @@ set(MOC_HDRS
     buffermodel.h
     bufferviewoverlay.h
     client.h
+    clientaliasmanager.h
     clientbacklogmanager.h
     clientbufferviewconfig.h
     clientbufferviewmanager.h
     clientcoreinfo.h
     clientidentity.h
+    clientignorelistmanager.h
     clientirclisthelper.h
     clientuserinputhandler.h
-    clientsyncer.h
+    coreaccountmodel.h
+    coreconnection.h
+    execwrapper.h
     irclistmodel.h
     messagefilter.h
     messagemodel.h
@@ -54,11 +73,17 @@ set(HEADERS
     backlogsettings.h
     backlogrequester.h
     buffersettings.h
-    clientsettings.h)
+    clientsettings.h
+    coreaccount.h
+   )
 
-qt4_wrap_cpp(MOC ${MOC_HDRS})
+include_directories(${CMAKE_SOURCE_DIR}/src/common ${QUASSEL_QT_INCLUDES})
 
-include_directories(${CMAKE_SOURCE_DIR}/src/common)
+if(NOT WITH_QT5)
+  qt4_wrap_cpp(MOC ${MOC_HDRS})
+endif(NOT WITH_QT5)
 
 add_library(mod_client STATIC ${SOURCES} ${MOC} ${HEADERS})
 add_dependencies(mod_client mod_common)
+
+set_target_properties(mod_client PROPERTIES COMPILE_FLAGS "${QUASSEL_QT_COMPILEFLAGS}")