Automatically synchronize CoreInfo when on connect and disconnect
[quassel.git] / src / client / CMakeLists.txt
index 935ba86..7e171d2 100644 (file)
@@ -31,21 +31,20 @@ set(SOURCES
     messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
+    transfermodel.cpp
     treemodel.cpp
 
     # needed for automoc
     abstractui.h
-    clientcoreinfo.h
 )
 
 if (USE_QT5)
     list(APPEND qt_modules Widgets)
 endif()
 
-if (HAVE_DBUS)
-    list(APPEND qt_modules DBus)
-endif()
+qt_add_resources(SOURCES ${CLIENT_RCS})
 
 add_library(mod_client STATIC ${SOURCES})
 qt_use_modules(mod_client Network Core Gui ${qt_modules})
-add_dependencies(mod_client mod_common)
+
+target_link_libraries(mod_client mod_common)