qt4-b-gone: Reorganize the initialization sequence
[quassel.git] / src / client / CMakeLists.txt
index 4f0106c..783e8dd 100644 (file)
@@ -1,7 +1,6 @@
 # Builds the client module
 
-# In Qt4, we still have some minor deps to QtGui: QItemSelectionModel, QSortFilterProxyModel
-# Still in Qt5: QAbstractItemView in BufferModel
+# We still have a minor dep to QtWidgets: QAbstractItemView in BufferModel
 
 set(SOURCES
     abstractmessageprocessor.cpp
@@ -31,29 +30,16 @@ set(SOURCES
     messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
+    transfermodel.cpp
     treemodel.cpp
 
     # needed for automoc
     abstractui.h
-    clientcoreinfo.h
 )
 
-if (KDE4_FOUND)
-    include_directories(${KDE4_INCLUDES})
-    add_definitions(-DHAVE_KDE ${KDE4_DEFINITIONS})
-endif()
-
-if (USE_QT5)
-    list(APPEND qt_modules Widgets)
-endif()
-
-qt_add_resources(SOURCES ${CLIENT_RCS})
+qt5_add_resources(SOURCES ${CLIENT_RCS})
 
 add_library(mod_client STATIC ${SOURCES})
-qt_use_modules(mod_client Network Core Gui ${qt_modules})
+qt5_use_modules(mod_client Network Core Gui Widgets)
 
 target_link_libraries(mod_client mod_common)
-
-if (KDE4_FOUND)
-    target_link_libraries(mod_client ${KDE4_SOLID_LIBS})
-endif()