qt4-b-gone: Remove all code supporting Qt < 5.5 and KDE4
[quassel.git] / src / client / CMakeLists.txt
index 3ad8f7d..783e8dd 100644 (file)
@@ -1,8 +1,45 @@
-SET(client_SRCS buffer.cpp buffertreemodel.cpp client.cpp clientsettings.cpp treemodel.cpp)
-SET(client_HDRS )
-SET(client_MOCS buffer.h buffertreemodel.h client.h clientsettings.h quasselui.h treemodel.h)
+# Builds the client module
 
-QT4_WRAP_CPP(_MOC ${client_MOCS})
+# We still have a minor dep to QtWidgets: QAbstractItemView in BufferModel
 
-ADD_LIBRARY(client ${client_SRCS} ${_MOC})
-TARGET_LINK_LIBRARIES(client common)
\ No newline at end of file
+set(SOURCES
+    abstractmessageprocessor.cpp
+    backlogrequester.cpp
+    buffermodel.cpp
+    buffersettings.cpp
+    bufferviewoverlay.cpp
+    client.cpp
+    clientaliasmanager.cpp
+    clientauthhandler.cpp
+    clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
+    clientignorelistmanager.cpp
+    clientirclisthelper.cpp
+    clientsettings.cpp
+    clienttransfer.cpp
+    clienttransfermanager.cpp
+    clientuserinputhandler.cpp
+    coreaccount.cpp
+    coreaccountmodel.cpp
+    coreconnection.cpp
+    execwrapper.cpp
+    irclistmodel.cpp
+    messagefilter.cpp
+    messagemodel.cpp
+    networkmodel.cpp
+    selectionmodelsynchronizer.cpp
+    transfermodel.cpp
+    treemodel.cpp
+
+    # needed for automoc
+    abstractui.h
+)
+
+qt5_add_resources(SOURCES ${CLIENT_RCS})
+
+add_library(mod_client STATIC ${SOURCES})
+qt5_use_modules(mod_client Network Core Gui Widgets)
+
+target_link_libraries(mod_client mod_common)