modernize: Remove old-style slot usage in NetworkModelController
[quassel.git] / src / client / CMakeLists.txt
index f23c62c..756a540 100644 (file)
@@ -1,8 +1,9 @@
-quassel_add_module(Client)
+quassel_add_module(Client EXPORT)
 
 target_sources(${TARGET} PRIVATE
     abstractmessageprocessor.cpp
     backlogrequester.cpp
+    backlogsettings.cpp
     buffermodel.cpp
     buffersettings.cpp
     bufferviewoverlay.cpp
@@ -33,8 +34,6 @@ target_sources(${TARGET} PRIVATE
 
     # needed for automoc
     abstractui.h
-
-    ${CLIENT_RCS}
 )
 
 target_link_libraries(${TARGET}
@@ -45,3 +44,9 @@ target_link_libraries(${TARGET}
         Qt5::Widgets  # QAbstractItemView in BufferModel
         Quassel::Common
 )
+
+if (EMBED_DATA)
+    set_property(SOURCE client.cpp APPEND PROPERTY COMPILE_DEFINITIONS EMBED_DATA)
+endif()
+
+target_link_if_exists(${TARGET} PUBLIC Quassel::Resource::Data)