cmake: Autogenerate most of the .qrc resource files
[quassel.git] / src / client / CMakeLists.txt
index 41721bd..6f4f669 100644 (file)
@@ -1,54 +1,47 @@
-# Builds the client module
+quassel_add_module(Client)
 
-# We still have some minor deps to QtUi: QItemSelectionModel
-# set(QT_DONT_USE_QTGUI 1)
-set(QT_USE_QTNETWORK 1)
-set(QT_USE_QTDBUS 1)
-include(${QT_USE_FILE})
-
-set(SOURCES
-    buffer.cpp
+target_sources(${TARGET} PRIVATE
+    abstractmessageprocessor.cpp
+    backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
+    bufferviewoverlay.cpp
     client.cpp
+    clientaliasmanager.cpp
+    clientauthhandler.cpp
     clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
+    clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
-    clientsyncer.cpp
+    clienttransfer.cpp
+    clienttransfermanager.cpp
+    clientuserinputhandler.cpp
+    coreaccount.cpp
+    coreaccountmodel.cpp
+    coreconnection.cpp
+    execwrapper.cpp
     irclistmodel.cpp
-    mappedselectionmodel.cpp
+    messagefilter.cpp
+    messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
-    treemodel.cpp)
-
-set(MOC_HDRS
-    buffer.h
-    buffermodel.h
-    client.h
-    clientbacklogmanager.h
-    clientcoreinfo.h
-    clientirclisthelper.h
-    clientsyncer.h
-    irclistmodel.h
-    networkmodel.h
-    mappedselectionmodel.h
-    quasselui.h
-    selectionmodelsynchronizer.h
-    treemodel.h)
-
-set(HEADERS
-    buffersettings.h
-    clientsettings.h)
-
-if(SPUTDEV)
-  set(SOURCES ${SOURCES} messagefilter.cpp messagemodel.cpp)
-  set(MOC_HDRS ${MOC_HDRS} messagefilter.h messagemodel.h)
-endif(SPUTDEV)
-
-qt4_wrap_cpp(MOC ${MOC_HDRS})
-
-include_directories(${CMAKE_SOURCE_DIR}/src/common)
-
-add_library(mod_client STATIC ${SOURCES} ${MOC} ${HEADERS})
-add_dependencies(mod_client mod_common)
-
+    transfermodel.cpp
+    treemodel.cpp
+
+    # needed for automoc
+    abstractui.h
+)
+
+target_link_libraries(${TARGET}
+    PUBLIC
+        Qt5::Core
+        Qt5::Gui
+        Qt5::Network
+        Qt5::Widgets  # QAbstractItemView in BufferModel
+        Quassel::Common
+)
+
+target_link_if_exists(${TARGET} PUBLIC Quassel::Resource::Data)