included qca2 into build system
[quassel.git] / src / client / CMakeLists.txt
index db78880..53fc761 100644 (file)
@@ -6,46 +6,69 @@ set(QT_USE_QTNETWORK 1)
 set(QT_USE_QTDBUS 1)
 include(${QT_USE_FILE})
 
+if (QCA2_FOUND)
+  include_directories(${QCA2_INCLUDE_DIR})
+endif (QCA2_FOUND)
+
 set(SOURCES
-    buffer.cpp
+    abstractmessageprocessor.cpp
+    backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
+    bufferviewoverlay.cpp
     client.cpp
+    clientaliasmanager.cpp
     clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
+    clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
-    clientsyncer.cpp
-    desktopnotifications.cpp
+    clientuserinputhandler.cpp
+    coreaccount.cpp
+    coreaccountmodel.cpp
+    coreconnection.cpp
+    execwrapper.cpp
     irclistmodel.cpp
-    mappedselectionmodel.cpp
+    messagefilter.cpp
+    messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
     treemodel.cpp)
 
 set(MOC_HDRS
-    buffer.h
+    abstractmessageprocessor.h
+    abstractui.h
     buffermodel.h
+    bufferviewoverlay.h
     client.h
+    clientaliasmanager.h
     clientbacklogmanager.h
+    clientbufferviewconfig.h
+    clientbufferviewmanager.h
     clientcoreinfo.h
+    clientidentity.h
+    clientignorelistmanager.h
     clientirclisthelper.h
-    clientsyncer.h
-    desktopnotifications.h
+    clientuserinputhandler.h
+    coreaccountmodel.h
+    coreconnection.h
+    execwrapper.h
     irclistmodel.h
+    messagefilter.h
+    messagemodel.h
     networkmodel.h
-    mappedselectionmodel.h
-    quasselui.h
     selectionmodelsynchronizer.h
     treemodel.h)
 
 set(HEADERS
+    backlogsettings.h
+    backlogrequester.h
     buffersettings.h
-    clientsettings.h)
-
-if(SPUTDEV)
-  set(SOURCES ${SOURCES} messagefilter.cpp messagemodel.cpp)
-  set(MOC_HDRS ${MOC_HDRS} messagefilter.h messagemodel.h)
-endif(SPUTDEV)
+    clientsettings.h
+    coreaccount.h
+   )
 
 qt4_wrap_cpp(MOC ${MOC_HDRS})
 
@@ -53,4 +76,3 @@ include_directories(${CMAKE_SOURCE_DIR}/src/common)
 
 add_library(mod_client STATIC ${SOURCES} ${MOC} ${HEADERS})
 add_dependencies(mod_client mod_common)
-