included qca2 into build system
[quassel.git] / src / client / CMakeLists.txt
index c009f5b..53fc761 100644 (file)
@@ -6,9 +6,12 @@ set(QT_USE_QTNETWORK 1)
 set(QT_USE_QTDBUS 1)
 include(${QT_USE_FILE})
 
+if (QCA2_FOUND)
+  include_directories(${QCA2_INCLUDE_DIR})
+endif (QCA2_FOUND)
+
 set(SOURCES
     abstractmessageprocessor.cpp
-    abstractui.cpp
     backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
@@ -22,10 +25,10 @@ set(SOURCES
     clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
-    clientsyncer.cpp
     clientuserinputhandler.cpp
     coreaccount.cpp
     coreaccountmodel.cpp
+    coreconnection.cpp
     execwrapper.cpp
     irclistmodel.cpp
     messagefilter.cpp
@@ -49,8 +52,8 @@ set(MOC_HDRS
     clientignorelistmanager.h
     clientirclisthelper.h
     clientuserinputhandler.h
-    clientsyncer.h
     coreaccountmodel.h
+    coreconnection.h
     execwrapper.h
     irclistmodel.h
     messagefilter.h