included qca2 into build system
[quassel.git] / src / client / CMakeLists.txt
index 31fa5d7..53fc761 100644 (file)
@@ -6,9 +6,12 @@ set(QT_USE_QTNETWORK 1)
 set(QT_USE_QTDBUS 1)
 include(${QT_USE_FILE})
 
+if (QCA2_FOUND)
+  include_directories(${QCA2_INCLUDE_DIR})
+endif (QCA2_FOUND)
+
 set(SOURCES
     abstractmessageprocessor.cpp
-    abstractui.cpp
     backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
@@ -22,7 +25,6 @@ set(SOURCES
     clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
-    clientsyncer.cpp
     clientuserinputhandler.cpp
     coreaccount.cpp
     coreaccountmodel.cpp
@@ -50,7 +52,6 @@ set(MOC_HDRS
     clientignorelistmanager.h
     clientirclisthelper.h
     clientuserinputhandler.h
-    clientsyncer.h
     coreaccountmodel.h
     coreconnection.h
     execwrapper.h