Moving quasselui.h from common/ to client/ where it belongs.
[quassel.git] / src / client / CMakeLists.txt
index 40a7695..3ad8f7d 100644 (file)
@@ -1,6 +1,8 @@
-SET(client_SRCS buffer.cpp buffertreemodel.cpp client.cpp clientproxy.cpp treemodel.cpp)
+SET(client_SRCS buffer.cpp buffertreemodel.cpp client.cpp clientsettings.cpp treemodel.cpp)
 SET(client_HDRS )
-SET(client_MOCS buffer.h buffertreemodel.h client.h clientproxy.h treemodel.h)
+SET(client_MOCS buffer.h buffertreemodel.h client.h clientsettings.h quasselui.h treemodel.h)
 
 QT4_WRAP_CPP(_MOC ${client_MOCS})
-ADD_LIBRARY(client ${_MOC} ${client_SRCS} ${client_HDRS})
+
+ADD_LIBRARY(client ${client_SRCS} ${_MOC})
+TARGET_LINK_LIBRARIES(client common)
\ No newline at end of file