Prevent ChatView from scrolling up 1px on buffer switch, fixes #544
[quassel.git] / src / client / CMakeLists.txt
index d4a2459..044565b 100644 (file)
@@ -7,40 +7,48 @@ set(QT_USE_QTDBUS 1)
 include(${QT_USE_FILE})
 
 set(SOURCES
-    buffer.cpp
+    abstractmessageprocessor.cpp
+    abstractui.cpp
+    backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
     client.cpp
     clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
     clientsyncer.cpp
     irclistmodel.cpp
     messagefilter.cpp
     messagemodel.cpp
-    mappedselectionmodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
     treemodel.cpp)
 
 set(MOC_HDRS
-    buffer.h
+    abstractmessageprocessor.h
+    abstractui.h
     buffermodel.h
     client.h
     clientbacklogmanager.h
+    clientbufferviewconfig.h
+    clientbufferviewmanager.h
     clientcoreinfo.h
+    clientidentity.h
     clientirclisthelper.h
     clientsyncer.h
     irclistmodel.h
     messagefilter.h
     messagemodel.h
     networkmodel.h
-    mappedselectionmodel.h
-    quasselui.h
     selectionmodelsynchronizer.h
     treemodel.h)
 
 set(HEADERS
+    backlogsettings.h
+    backlogrequester.h
     buffersettings.h
     clientsettings.h)