Prevent ChatView from scrolling up 1px on buffer switch, fixes #544
[quassel.git] / src / client / CMakeLists.txt
index 39436cb..044565b 100644 (file)
@@ -3,46 +3,58 @@
 # We still have some minor deps to QtUi: QItemSelectionModel
 # set(QT_DONT_USE_QTGUI 1)
 set(QT_USE_QTNETWORK 1)
+set(QT_USE_QTDBUS 1)
 include(${QT_USE_FILE})
 
 set(SOURCES
-    buffer.cpp
+    abstractmessageprocessor.cpp
+    abstractui.cpp
+    backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
     client.cpp
     clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
+    clientirclisthelper.cpp
     clientsettings.cpp
     clientsyncer.cpp
-    mappedselectionmodel.cpp
+    irclistmodel.cpp
+    messagefilter.cpp
+    messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
     treemodel.cpp)
 
 set(MOC_HDRS
-    buffer.h
+    abstractmessageprocessor.h
+    abstractui.h
     buffermodel.h
     client.h
     clientbacklogmanager.h
+    clientbufferviewconfig.h
+    clientbufferviewmanager.h
+    clientcoreinfo.h
+    clientidentity.h
+    clientirclisthelper.h
     clientsyncer.h
+    irclistmodel.h
+    messagefilter.h
+    messagemodel.h
     networkmodel.h
-    mappedselectionmodel.h
-    quasselui.h
     selectionmodelsynchronizer.h
     treemodel.h)
 
 set(HEADERS
+    backlogsettings.h
+    backlogrequester.h
     buffersettings.h
     clientsettings.h)
 
-if(SPUTDEV)
-  set(SOURCES ${SOURCES} messagefilter.cpp messagemodel.cpp)
-  set(MOC_HDRS ${MOC_HDRS} messagefilter.h messagemodel.h)
-endif(SPUTDEV)
-
 qt4_wrap_cpp(MOC ${MOC_HDRS})
 
 include_directories(${CMAKE_SOURCE_DIR}/src/common)
 
 add_library(mod_client STATIC ${SOURCES} ${MOC} ${HEADERS})
 add_dependencies(mod_client mod_common)
-