Completely rework the dependency handling in the build system
[quassel.git] / src / client / CMakeLists.txt
index 935ba86..bc74ecc 100644 (file)
@@ -38,14 +38,20 @@ set(SOURCES
     clientcoreinfo.h
 )
 
-if (USE_QT5)
-    list(APPEND qt_modules Widgets)
+if (KDE4_FOUND)
+    include_directories(${KDE4_INCLUDES})
+    add_definitions(-DHAVE_KDE ${KDE4_DEFINITIONS})
 endif()
 
-if (HAVE_DBUS)
-    list(APPEND qt_modules DBus)
+if (USE_QT5)
+    list(APPEND qt_modules Widgets)
 endif()
 
 add_library(mod_client STATIC ${SOURCES})
 qt_use_modules(mod_client Network Core Gui ${qt_modules})
+
+if (KDE4_FOUND)
+    target_link_libraries(mod_client ${KDE4_SOLID_LIBS})
+endif()
+
 add_dependencies(mod_client mod_common)