Happy New Year!
[quassel.git] / src / CMakeLists.txt
index d165e62..59facd8 100644 (file)
@@ -1,72 +1,74 @@
 # Builds the three main targets
 
-# Define resources for icons and pics, if needed
-# We always add stuff in :/pics
-qt4_add_resources(CLIENT_DEPS ../pics/pics.qrc)
-
-if(QUASSEL_ICONS MATCHES "Builtin")
-  set(CLIENT_DEPS ${CLIENT_DEPS} ../icons/qrc_hicolor.cxx)
-  set_source_files_properties(../icons/qrc_hicolor.cxx PROPERTIES GENERATED true)
-  add_definitions(-DQUASSEL_ICONS_BUILTIN)
-endif(QUASSEL_ICONS MATCHES "Builtin")
-
-if(OXYGEN_ICONS MATCHES "Builtin")
-  set(CLIENT_DEPS ${CLIENT_DEPS} ../icons/qrc_oxygen.cxx)
-  set_source_files_properties(../icons/qrc_oxygen.cxx PROPERTIES GENERATED true)
-  add_definitions(-DOXYGEN_ICONS_BUILTIN)
-endif(OXYGEN_ICONS MATCHES "Builtin")
-
-# Now it's time to build the modules...
-
 add_subdirectory(common)
-include_directories(common)
-if(WANT_CORE OR WANT_MONO)
+include_directories(BEFORE common)
+if(BUILD_CORE)
   add_subdirectory(core)
-  include_directories(core)
-endif(WANT_CORE OR WANT_MONO)
-if(WANT_QTCLIENT OR WANT_MONO)
+  include_directories(BEFORE core)
+endif(BUILD_CORE)
+if(BUILD_GUI)
   add_subdirectory(client)
   add_subdirectory(uisupport)
   add_subdirectory(qtui)
-  include_directories(client)
-  include_directories(uisupport)
-  include_directories(qtui)
-endif(WANT_QTCLIENT OR WANT_MONO)
+  include_directories(BEFORE client)
+  include_directories(BEFORE uisupport)
+  include_directories(BEFORE qtui)
+
+  if(STATIC)
+    link_directories(${QT_PLUGINS_DIR}/imageformats)
+    set(CLIENT_LIBRARIES ${CLIENT_LIBRARIES} qjpeg qgif)
+  endif(STATIC)
+endif(BUILD_GUI)
 
-# ... and finally the executables
+include_directories(BEFORE ${CMAKE_CURRENT_BINARY_DIR}) # for version.gen
+
+# We need to initialize the appropriate resources, so let's give our main.cpp some hints
+if (EMBED_DATA)
+    add_definitions(-DEMBED_DATA)
+endif()
+if (WITH_OXYGEN)
+    add_definitions(-DWITH_OXYGEN)
+endif()
+
+# Needed for showing the cli option if appropriate
+if (HAVE_SYSLOG)
+    add_definitions(-DHAVE_SYSLOG)
+endif()
 
 if(WANT_CORE)
-  setup_qt4_variables(NETWORK SCRIPT SQL)
-  add_executable(quasselcore common/main.cpp ${COMMON_DEPS} ${CORE_DEPS})
+  add_executable(quasselcore common/main.cpp ${CORE_DEPS} ${COMMON_DEPS})
+  qt_use_modules(quasselcore Core Network ${CORE_QT_MODULES})
+  add_dependencies(quasselcore po)
   set_target_properties(quasselcore PROPERTIES
-                                    COMPILE_FLAGS "-DQT_NETWORK_LIB -DQT_SCRIPT_LIB -DQT_SQL_LIB -DBUILD_CORE"
+                                    COMPILE_FLAGS "-DBUILD_CORE"
                                     OUTPUT_NAME ../quasselcore)
-  target_link_libraries(quasselcore mod_core mod_common
-                                    ${QUASSEL_QT_LIBRARIES} ${QUASSEL_SSL_LIBRARIES})
+  target_link_libraries(quasselcore mod_core mod_common ${COMMON_LIBRARIES} ${QUASSEL_SSL_LIBRARIES} ${QT_QTMAIN_LIBRARY})
   install(TARGETS quasselcore RUNTIME DESTINATION ${BIN_INSTALL_DIR})
 endif(WANT_CORE)
 
+if (KDE4_FOUND)
+    include_directories(${KDE4_INCLUDES})
+endif()
+
 if(WANT_QTCLIENT)
-  setup_qt4_variables(${LINK_DBUS} GUI NETWORK ${LINK_WEBKIT})
-  add_executable(quasselclient WIN32 common/main.cpp ${COMMON_DEPS} ${CLIENT_DEPS})
-  add_dependencies(quasselclient icons)
+  add_executable(quasselclient WIN32 common/main.cpp ${CLIENT_DEPS} ${COMMON_DEPS})
+  qt_use_modules(quasselclient Core Gui Network ${CLIENT_QT_MODULES})
+  add_dependencies(quasselclient po)
   set_target_properties(quasselclient PROPERTIES
-                                      COMPILE_FLAGS "-DQT_GUI_LIB -DQT_NETWORK_LIB -DBUILD_QTUI"
+                                      COMPILE_FLAGS "-DBUILD_QTUI"
                                       OUTPUT_NAME ../quasselclient)
-  target_link_libraries(quasselclient mod_qtui mod_uisupport mod_client mod_common
-                                      ${QUASSEL_QT_LIBRARIES} ${QUASSEL_SSL_LIBRARIES})
+  target_link_libraries(quasselclient mod_qtui mod_uisupport mod_client mod_common ${COMMON_LIBRARIES} ${CLIENT_LIBRARIES} ${QUASSEL_SSL_LIBRARIES} ${QT_QTMAIN_LIBRARY})
   install(TARGETS quasselclient RUNTIME DESTINATION ${BIN_INSTALL_DIR})
 endif(WANT_QTCLIENT)
 
 if(WANT_MONO)
-  setup_qt4_variables(${LINK_DBUS} GUI NETWORK SCRIPT SQL ${LINK_WEBKIT})
-  add_executable(quassel WIN32 common/main.cpp qtui/monoapplication.cpp ${COMMON_DEPS} ${CLIENT_DEPS} ${CORE_DEPS})
-  add_dependencies(quassel icons)
+  add_executable(quassel WIN32 common/main.cpp qtui/monoapplication.cpp ${CLIENT_DEPS} ${CORE_DEPS} ${COMMON_DEPS})
+  qt_use_modules(quassel Core Gui Network ${CLIENT_QT_MODULES} ${CORE_QT_MODULES})
+  add_dependencies(quassel po)
   set_target_properties(quassel PROPERTIES
-                                COMPILE_FLAGS "-DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_SCRIPT_LIB -DQT_SQL_LIB -DBUILD_MONO"
+                                COMPILE_FLAGS "-DBUILD_MONO"
                                 OUTPUT_NAME ../quassel)
-  target_link_libraries(quassel mod_qtui mod_uisupport mod_client mod_core mod_common
-                                ${QUASSEL_QT_LIBRARIES} ${QUASSEL_SSL_LIBRARIES})
+  target_link_libraries(quassel mod_qtui mod_uisupport mod_client mod_core mod_common ${COMMON_LIBRARIES} ${CLIENT_LIBRARIES} ${QUASSEL_SSL_LIBRARIES} ${QT_QTMAIN_LIBRARY})
   install(TARGETS quassel RUNTIME DESTINATION ${BIN_INSTALL_DIR})
 endif(WANT_MONO)
 
@@ -83,5 +85,7 @@ if(APPLE)
                        COMMAND ${CMAKE_SOURCE_DIR}/scripts/build/macosx_makePackage.sh Client ..)
     add_custom_command(TARGET quasselcore POST_BUILD
                        COMMAND ${CMAKE_SOURCE_DIR}/scripts/build/macosx_makePackage.sh Core ..)
+    add_custom_command(TARGET quasselcore POST_BUILD
+                       COMMAND ${CMAKE_SOURCE_DIR}/scripts/build/macosx_makePackage.sh Mono ..)
   endif(DEPLOY)
 endif(APPLE)