test: Add build system support and a main function for unit tests
[quassel.git] / src / CMakeLists.txt
index 7b2a512..130144b 100644 (file)
@@ -8,3 +8,7 @@ if (BUILD_GUI)
     add_subdirectory(uisupport)
     add_subdirectory(qtui)
 endif()
+
+if (BUILD_TESTING)
+    add_subdirectory(test)
+endif()