Work-in-progress: use progress bar
[quassel.git] / src / CMakeLists.txt
index d84f7df..07d2f2f 100644 (file)
@@ -20,15 +20,16 @@ IF(BUILD MATCHES "mono" OR BUILD MATCHES "all")
   SET(BUILD_MONO true)
   MESSAGE("Building monolithic Quassel.")
 ENDIF(BUILD MATCHES "mono" OR BUILD MATCHES "all")
-IF(NOT BUILD_MONO AND NOT BUILD_CORE AND NOT BUILD_GUI)
+IF(NOT BUILD_MONO AND NOT BUILD_CORE AND NOT BUILD_QTGUI)
   MESSAGE(FATAL_ERROR "\nYou have not selected which parts of Quassel I should build. Aborting.\nRun 'cmake <path> -DBUILD=<part>', where <part> contains one or more of 'core', 'gui' or 'monolithic', or 'all' to build everything.\n")
-ENDIF(NOT BUILD_MONO AND NOT BUILD_CORE AND NOT BUILD_GUI)
+ENDIF(NOT BUILD_MONO AND NOT BUILD_CORE AND NOT BUILD_QTGUI)
 
-IF(BUILD_CORE OR BUILD_QTGUI)
-  MESSAGE(FATAL_ERROR "\nBuilding of standalone core or GUI not supported at this time. Please check back later.\n")
-ENDIF(BUILD_CORE OR BUILD_QTGUI)
+#IF(BUILD_CORE OR BUILD_QTGUI)
+#  MESSAGE(FATAL_ERROR "\nBuilding of standalone core or GUI not supported at this time. Please check back later.\n")
+#ENDIF(BUILD_CORE OR BUILD_QTGUI)
 
 SET(CMAKE_BUILD_TYPE Debug)
+SET(GCC_WARN "-Wall -Wextra -ansi -Wno-unused-parameter")  # may not be portable!
 
 # Define files
 SET(quassel_mono_SRCS common/build_mono.cpp)
@@ -53,9 +54,12 @@ FIND_PACKAGE(Qt4 REQUIRED)
 SET(QT_USE_QTXML true)
 SET(QT_USE_QTSQL true)
 SET(QT_USE_QTNETWORK true)
+SET(QT_USE_QTUITOOLS true)
 SET(QT_DONT_USE_QTGUI true)   # This is added later if GUI is requested
 INCLUDE(${QT_USE_FILE})
 
+ADD_DEFINITIONS(${GCC_WARN})
+
 # Define subdirs. CMake complains if a directory is added twice, so make sure this
 # does not happen in any combination of the requested targets.
 
@@ -93,7 +97,7 @@ IF(BUILD_QTGUI OR BUILD_MONO)  # OK, now we need QtGui!
   ENDIF(BUILD_MONO)
 
   IF(BUILD_QTGUI)
-    ADD_EXECUTABLE(quasselclient ${quassel_gui_SRCS} ${_RCCS})
+    ADD_EXECUTABLE(quasselclient ${quassel_qtgui_SRCS} ${_RCCS})
     TARGET_LINK_LIBRARIES(quasselclient common client qtgui ${QT_LIBRARIES})
     SET(TARGET_LIST ${TARGET_LIST} quasselclient)
   ENDIF(BUILD_QTGUI)