Always include the Qt translations on Win32 Builds
[quassel.git] / po / CMakeLists.txt
index 59c2397..303ad23 100644 (file)
@@ -2,24 +2,24 @@
 # The LINGUAS variable can be used to limit that set
 
 if(QT_LCONVERT_EXECUTABLE)
-  # We always include quassel.po
-  generate_qm(QM quassel)
-  set(qm_files ${QM})
-
   # get environment variable for translations
   set(LINGUAS "$ENV{LINGUAS}")
   string(REGEX REPLACE "[ \t]+" \; output "${LINGUAS}")
   # Find more languages
-  file(GLOB avail_pofiles quassel_*.po qt_*.po)
+  # We support xx.po and xx_YY.po, and additionally translations for qt using qt_xx.po or qt_xx_YY.po
+  file(GLOB avail_pofiles *.po)
   foreach(PO_FILE ${avail_pofiles})
     get_filename_component(basename ${PO_FILE} NAME_WE)
-    string(REGEX REPLACE "q[^_]+_([a-zA-Z]+)(_.+)?$" "\\1" lang ${basename})
-    # test if we want this
+    # CMake can't use MATCH to get the second catch...
+    string(REGEX REPLACE "(qt_)?([a-zA-Z]+)(_.+)?$" "\\2" lang ${basename})
+
+    # test if we want this language
     set(flg 1)
     if(LINGUAS)
       string(REGEX MATCH "${lang}" flg ${LINGUAS})
     endif(LINGUAS)
     if(flg)
+      generate_ts(QM ${basename})
       generate_qm(QM ${basename})
       list(APPEND qm_files ${QM})
       list(APPEND gen_linguas ${lang})
@@ -33,8 +33,8 @@ else(QT_LCONVERT_EXECUTABLE)
   message(STATUS "WARNING: lconvert not found, you won't have translations!")
 endif(QT_LCONVERT_EXECUTABLE)
 
-# For a static build, we need to include Qt translations if available
-if(STATIC AND QT_TRANSLATIONS_DIR)
+# For a static or win32 build, we need to include Qt translations if available
+if((STATIC OR WIN32) AND QT_TRANSLATIONS_DIR)
   foreach(LANG ${gen_linguas})
     file(GLOB lang_files ${QT_TRANSLATIONS_DIR}/qt_${LANG}*.qm)
     foreach(absfile ${lang_files})
@@ -44,7 +44,7 @@ if(STATIC AND QT_TRANSLATIONS_DIR)
       list(APPEND qm_files ${CMAKE_CURRENT_BINARY_DIR}/${filename})
     endforeach(absfile ${lang_files})
   endforeach(LANG ${gen_linguas})
-endif(STATIC AND QT_TRANSLATIONS_DIR)
+endif((STATIC OR WIN32) AND QT_TRANSLATIONS_DIR)
 
 # Write resource file
 set(resfile ${CMAKE_CURRENT_BINARY_DIR}/i18n.qrc)