Remove arguments of CMake's else() and endif() commands
[quassel.git] / po / CMakeLists.txt
index 1980a58..03a6d05 100644 (file)
@@ -17,21 +17,21 @@ if(QT_LCONVERT_EXECUTABLE)
     set(flg 1)
     if(LINGUAS)
       string(REGEX MATCH "${lang}" flg ${LINGUAS})
-    endif(LINGUAS)
+    endif()
     if(flg)
       generate_ts(QM ${basename})
       generate_qm(QM ${basename})
       list(APPEND qm_files ${QM})
       list(APPEND gen_linguas ${lang})
-    endif(flg)
+    endif()
   endforeach(PO_FILE ${avail_pofiles})
   if(gen_linguas)
     list(REMOVE_DUPLICATES gen_linguas)
-  endif(gen_linguas)
+  endif()
   message(STATUS "Including languages: ${gen_linguas}")
-else(QT_LCONVERT_EXECUTABLE)
+else()
   message(STATUS "WARNING: lconvert not found, you won't have translations!")
-endif(QT_LCONVERT_EXECUTABLE)
+endif()
 
 # For a static or win32 build, we need to include Qt translations if available
 if(QT_TRANSLATIONS_DIR)
@@ -45,8 +45,8 @@ if(QT_TRANSLATIONS_DIR)
         list(APPEND qm_files ${CMAKE_CURRENT_BINARY_DIR}/${filename})
       endforeach(absfile ${lang_files})
     endforeach(LANG ${gen_linguas})
-  endif(STATIC OR WIN32)
-endif(QT_TRANSLATIONS_DIR)
+  endif()
+endif()
 
 # Write resource file
 set(resfile ${CMAKE_CURRENT_BINARY_DIR}/i18n.qrc)
@@ -63,8 +63,8 @@ set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES "${qm_files};i18
 
 if(EMBED_DATA)
   set(COMMON_RCS ${COMMON_RCS} ${resfile} PARENT_SCOPE)
-else(EMBED_DATA)
+else()
   install(FILES ${qm_files} DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/translations)
-endif(EMBED_DATA)
+endif()
 
 add_custom_target(po DEPENDS ${qm_files})