cmake: Remove build system support for Qt4/KDE4
[quassel.git] / icons / CMakeLists.txt
index 7f3f6a2..ca4df01 100644 (file)
@@ -7,6 +7,9 @@ if (WANT_MONO OR WANT_QTCLIENT)
 
     set(BUNDLED_ICON_THEME_DIR ${CMAKE_SOURCE_DIR}/3rdparty/icons)
 
+    # Always embed a hicolor fallback containing the most important (e.g. tray) icons
+    list(APPEND ICON_RCS ${CMAKE_CURRENT_SOURCE_DIR}/hicolor_icons.qrc)
+
     if (EMBED_DATA)
         # Always embed quassel-specific icons
         message(STATUS "Embedding Quassel-specific icons")
@@ -55,6 +58,12 @@ if (WANT_MONO OR WANT_QTCLIENT)
         # hicolor contains the application icon in all relevant sizes
         install(DIRECTORY hicolor DESTINATION ${CMAKE_INSTALL_ICONDIR})
 
+        if (Qt5Core_VERSION VERSION_LESS 5.5.0)
+            # Qt < 5.5 doesn't seem to correctly load icons from injected themes
+            # Install Quassel-specific ones from Oxygen into hicolor as fallback
+            install(DIRECTORY oxygen/ DESTINATION ${CMAKE_INSTALL_ICONDIR}/hicolor)
+        endif()
+
         # For a system install, also copy to pixmaps
         if (CMAKE_INSTALL_PREFIX STREQUAL "/usr")
             install(FILES hicolor/48x48/apps/quassel.png DESTINATION /usr/share/pixmaps)