Clear fontMetrics cache on setFormat()
[quassel.git] / icons / CMakeLists.txt
index 3a04ba5..c917a06 100644 (file)
@@ -10,4 +10,12 @@ if(OXYGEN_ICONS MATCHES "Builtin")
   qt4_add_resources(RC_ICONS oxygen.qrc)
 endif(OXYGEN_ICONS MATCHES "Builtin")
 
+# Application icon
+if(NOT APPLE AND NOT WIN32)
+  install(FILES hicolor/48x48/apps/quassel.png DESTINATION ${ICON_INSTALL_DIR}/hicolor/48x48/apps)
+  if(CMAKE_INSTALL_PREFIX STREQUAL "/usr")
+    install(FILES hicolor/48x48/apps/quassel.png DESTINATION /usr/share/pixmaps)
+  endif(CMAKE_INSTALL_PREFIX STREQUAL "/usr")
+endif(NOT APPLE AND NOT WIN32)
+
 add_custom_target(icons DEPENDS ${RC_ICONS})