Update qrc's for new Icons and update Import Script
[quassel.git] / icons / CMakeLists.txt
index e7ed673..6ffb7ec 100644 (file)
@@ -1,6 +1,6 @@
 # Install icons
 #
-# We put the bundled oxygen icon theme in DATA_INSTALL_DIR rather than ICON_INSTALL_DIR,
+# We put the bundled oxygen icon theme in DATADIR rather than ICONDIR,
 # in order to avoid conflicts. As we add this directory to XDG_DATA_DIRS at runtime,
 # the bundled theme will be found by Qt only if there is no oxygen theme installed
 # in system directories.
 if (WANT_MONO OR WANT_QTCLIENT)
     set(ICON_RCS ${CMAKE_CURRENT_SOURCE_DIR}/hicolor.qrc) # always embed those
 
+    if (NOT WITH_OXYGEN)
+        message(STATUS "Not installing bundled Oxygen icons")
+    endif()
+
+    if (NOT WITH_BREEZE)
+        message(STATUS "Not installing bundled Breeze icons")
+    endif()
+
+    if (NOT WITH_BREEZE_DARK)
+        message(STATUS "Not installing bundled Breeze Dark icons")
+    endif()
+
     if (EMBED_DATA)
         if (WITH_OXYGEN)
             message(STATUS "Embedding bundled Oxygen icons")
             set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/oxygen.qrc)
         endif()
+        if (WITH_BREEZE)
+            message(STATUS "Embedding bundled Breeze icons")
+            set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/breeze.qrc)
+        endif()
+        if (WITH_BREEZE_DARK)
+            message(STATUS "Embedding bundled Breeze Dark icons")
+            set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/breezedark.qrc)
+        endif()
+
+        message(STATUS "Embedding some extra Oxygen styled icons")
+        set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/oxygen-extra.qrc)
+
+        message(STATUS "Embedding some extra Breeze styled icons")
+        set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/breeze-extra.qrc)
+
+        message(STATUS "Embedding some extra Breeze Dark styled icons")
+        set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/breezedark-extra.qrc)
+
     else()
-        install(DIRECTORY hicolor DESTINATION ${ICON_INSTALL_DIR})
+        install(DIRECTORY hicolor DESTINATION ${CMAKE_INSTALL_ICONDIR})
         if (WITH_OXYGEN)
             message(STATUS "Installing bundled Oxygen icons")
-            install(DIRECTORY oxygen DESTINATION ${DATA_INSTALL_DIR}/quassel/icons)
+            install(DIRECTORY oxygen DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons)
+        endif()
+        if (WITH_BREEZE)
+            message(STATUS "Installing bundled Breeze icons")
+            install(DIRECTORY breeze DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons)
+        endif()
+        if (WITH_BREEZE_DARK)
+            message(STATUS "Installing bundled Breeze Dark icons")
+            install(DIRECTORY breezedark DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons)
         endif()
-    endif()
 
-    if (NOT WITH_OXYGEN)
-        message(STATUS "Not installing bundled Oxygen icons")
+        message(STATUS "Installing some extra bundled Oxygen styled icons")
+        install(DIRECTORY extra-icons/oxygen DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons/extra)
+
+        message(STATUS "Installing some extra bundled Breeze styled icons")
+        install(DIRECTORY extra-icons/breeze DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons/extra)
+
+        message(STATUS "Installing some extra bundled Breeze Dark styled icons")
+        install(DIRECTORY extra-icons/breezedark DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons/extra)
     endif()
 
     set(CLIENT_RCS ${CLIENT_RCS} ${ICON_RCS} PARENT_SCOPE)
-endif()
-
-# Application icon
 
-if (HAVE_KDE OR (UNIX AND NOT APPLE))
-    install(FILES hicolor/48x48/apps/quassel.png DESTINATION ${ICON_INSTALL_DIR}/hicolor/48x48/apps)
-    if (CMAKE_INSTALL_PREFIX STREQUAL "/usr")
-        install(FILES hicolor/48x48/apps/quassel.png DESTINATION /usr/share/pixmaps)
+    # Application icon
+    if (HAVE_KDE OR (UNIX AND NOT APPLE))
+        install(FILES hicolor/48x48/apps/quassel.png DESTINATION ${CMAKE_INSTALL_ICONDIR}/hicolor/48x48/apps)
+        if (CMAKE_INSTALL_PREFIX STREQUAL "/usr")
+            install(FILES hicolor/48x48/apps/quassel.png DESTINATION /usr/share/pixmaps)
+        endif()
     endif()
 endif()