Lock Dock Positions has been replaced by Lock Layout
[quassel.git] / icons / CMakeLists.txt
index c917a06..5824c6e 100644 (file)
@@ -1,21 +1,18 @@
-# Build and/or install icons according to global settings
+# Install icons
+# We put them in DATA_INSTALL_DIR rather than ICON_INSTALL_DIR, to avoid
+# polluting the global namespace and to allow overriding
 
-if(QUASSEL_ICONS MATCHES "External")
-  install(DIRECTORY hicolor DESTINATION ${ICON_INSTALL_DIR})
-else(QUASSEL_ICONS MATCHES "External")
-  qt4_add_resources(RC_ICONS hicolor.qrc)
-endif(QUASSEL_ICONS MATCHES "External")
-
-if(OXYGEN_ICONS MATCHES "Builtin")
-  qt4_add_resources(RC_ICONS oxygen.qrc)
-endif(OXYGEN_ICONS MATCHES "Builtin")
+if(EMBED_DATA)
+  set(CLIENT_RCS ${CLIENT_RCS} ../icons/hicolor.qrc ../icons/oxygen.qrc PARENT_SCOPE)
+else(EMBED_DATA)
+  install(DIRECTORY hicolor DESTINATION ${DATA_INSTALL_DIR}/quassel/icons)
+  install(DIRECTORY oxygen DESTINATION ${DATA_INSTALL_DIR}/quassel/icons)
+endif(EMBED_DATA)
 
 # Application icon
 if(NOT APPLE AND NOT WIN32)
-  install(FILES hicolor/48x48/apps/quassel.png DESTINATION ${ICON_INSTALL_DIR}/hicolor/48x48/apps)
+  install(FILES oxygen/48x48/apps/quassel.png DESTINATION ${ICON_INSTALL_DIR}/hicolor/48x48/apps)
   if(CMAKE_INSTALL_PREFIX STREQUAL "/usr")
-    install(FILES hicolor/48x48/apps/quassel.png DESTINATION /usr/share/pixmaps)
+    install(FILES oxygen/48x48/apps/quassel.png DESTINATION /usr/share/pixmaps)
   endif(CMAKE_INSTALL_PREFIX STREQUAL "/usr")
 endif(NOT APPLE AND NOT WIN32)
-
-add_custom_target(icons DEPENDS ${RC_ICONS})