Add and Initialize Icon Themes
[quassel.git] / icons / CMakeLists.txt
index 1a25353..4ae47d5 100644 (file)
@@ -17,18 +17,42 @@ if (WANT_MONO OR WANT_QTCLIENT)
             message(STATUS "Embedding bundled Oxygen icons")
             set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/oxygen.qrc)
         endif()
+        if (WITH_BREEZE)
+            message(STATUS "Embedding bundled Breeze icons")
+            set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/breeze.qrc)
+        endif()
+        if (WITH_BREEZE_DARK)
+            message(STATUS "Embedding bundled Breeze Dark icons")
+            set(ICON_RCS ${ICON_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/breezedark.qrc)
+        endif()
     else()
         install(DIRECTORY hicolor DESTINATION ${CMAKE_INSTALL_ICONDIR})
         if (WITH_OXYGEN)
             message(STATUS "Installing bundled Oxygen icons")
             install(DIRECTORY oxygen DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons)
         endif()
+        if (WITH_BREEZE)
+            message(STATUS "Installing bundled Breeze icons")
+            install(DIRECTORY breeze DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons)
+        endif()
+        if (WITH_BREEZE_DARK)
+            message(STATUS "Installing bundled Breeze Dark icons")
+            install(DIRECTORY breezedark DESTINATION ${CMAKE_INSTALL_DATADIR}/quassel/icons)
+        endif()
     endif()
 
     if (NOT WITH_OXYGEN)
         message(STATUS "Not installing bundled Oxygen icons")
     endif()
 
+    if (NOT WITH_BREEZE)
+        message(STATUS "Not installing bundled Breeze icons")
+    endif()
+
+    if (NOT WITH_BREEZE_DARK)
+        message(STATUS "Not installing bundled Breeze Dark icons")
+    endif()
+
     set(CLIENT_RCS ${CLIENT_RCS} ${ICON_RCS} PARENT_SCOPE)
 endif()