icons: Add hicolor fallback for Qt < 5.5
[quassel.git] / icons / CMakeLists.txt
index b989db4..fab63f6 100644 (file)
@@ -7,6 +7,9 @@ if (WANT_MONO OR WANT_QTCLIENT)
 
     set(BUNDLED_ICON_THEME_DIR ${CMAKE_SOURCE_DIR}/3rdparty/icons)
 
+    # Always embed a hicolor fallback containing the most important (e.g. tray) icons
+    list(APPEND ICON_RCS ${CMAKE_CURRENT_SOURCE_DIR}/hicolor_icons.qrc)
+
     if (EMBED_DATA)
         # Always embed quassel-specific icons
         message(STATUS "Embedding Quassel-specific icons")
@@ -55,7 +58,7 @@ if (WANT_MONO OR WANT_QTCLIENT)
         # hicolor contains the application icon in all relevant sizes
         install(DIRECTORY hicolor DESTINATION ${CMAKE_INSTALL_ICONDIR})
 
-        if (USE_QT4)
+        if (USE_QT4 OR (USE_QT5 AND Qt5Core_VERSION VERSION_LESS 5.5.0))
             # Qt 4 doesn't seem to correctly load icons from injected themes
             # Install Quassel-specific ones from Oxygen into hicolor as fallback
             install(DIRECTORY oxygen/ DESTINATION ${CMAKE_INSTALL_ICONDIR}/hicolor)