cmake: Link resources statically, and init locally
[quassel.git] / icons / CMakeLists.txt
index 4780efc..35eae34 100644 (file)
@@ -9,7 +9,7 @@ if (WANT_MONO OR WANT_QTCLIENT)
 
     # Always embed a hicolor fallback containing the most important (e.g. tray) icons.
     # The .qrc contains aliases, so it's best to keep this manually written rather than autogenerated.
-    quassel_add_module(Resource::HicolorIcons)
+    quassel_add_module(Resource::HicolorIcons STATIC)
     target_sources(${TARGET} PRIVATE hicolor_icons.qrc)
     set_target_properties(${TARGET} PROPERTIES AUTOMOC OFF AUTOUIC OFF)